Google Workspace/Chrome OS
Incident Report for Meridian Technology
Resolved
Status: Resolved
Affected service: ChromeOS
Summary: The issue has been fully resolved. We apologize for the inconvenience and thank you for your patience and continued support.
Posted Aug 25, 2023 - 20:41 CDT
Update
Status: Ongoing
Affected service: ChromeOS
Summary: Our team is continuing to investigate this issue.
Next update estimate: Friday, Aug 25, 2023, 10:00:00 PM (UTC).
Posted Aug 25, 2023 - 15:35 CDT
Update
Status: Ongoing
Affected service: ChromeOS
Summary: Our team is continuing to investigate this issue.
Next update estimate: Friday, Aug 25, 2023, 7:30:00 PM (UTC).
Posted Aug 25, 2023 - 14:19 CDT
Investigating
Google is currently investigating an issue with Chrome OS.

The affected users are unable to access ChromeOS. Some users may experience issues logging into ChromeOS devices.

This issue has impacted Meridian student accounts.
Posted Aug 25, 2023 - 13:49 CDT
This incident affected: Google Workspace (ChromeOS).