Gmail - delays in sending emails
Incident Report for Meridian Technology
Resolved
This incident has been resolved.
Posted Nov 30, 2023 - 16:57 CST
Investigating
Customers impacted by this issue may see delay for a few mins while sending the emails.
Posted Nov 30, 2023 - 12:31 CST
This incident affected: Google Workspace (Google Mail).