Google Workspace
Incident Report for Meridian Technology
Resolved
From the Google Workspace team: The issue has been fully resolved. We apologize for the inconvenience and thank you for your patience and continued support.
Posted Feb 27, 2023 - 09:24 CST
Update
At this time, this Google Workspace outage does not appear to be affecting Meridian.
Posted Feb 27, 2023 - 08:44 CST
Update
We are continuing to investigate this issue.
Posted Feb 27, 2023 - 08:42 CST
Investigating
The Google Workspace Apps team is investigating an issue with Google Drive, Google Docs, Google Cloud Search, Google Voice, Google Chat, Google Calendar, Gmail, Google Tasks, and Google Meet
Posted Feb 27, 2023 - 08:38 CST
This incident affected: Google Workspace (Google Mail, Google Drive, Google Docs, Google Calendar, Google Meet).