Google Drive
Incident Report for Meridian Technology
Resolved
This incident has been resolved.
Posted Sep 14, 2023 - 09:43 CDT
Investigating
Google is currently investigating an issue with Google Drive:

"We're investigating reports of an issue with Google Drive. We will provide more information shortly. The affected users are able to access Google Drive, but are seeing error messages, high latency, and/or other unexpected behavior.

Customers can see "Your account doesn't support creating new files within Google Drive. You can still view and edit existing files." banner. Creating files works as expected despite of the message in the banner.

Workaround: customers can ignore the warning banner and create files."
Posted Sep 14, 2023 - 09:20 CDT
This incident affected: Google Workspace (Google Drive).