Raptor Service Interruption

Incident Report for Meridian Technology

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 07:52 CDT

Identified

From the Raptor team:

We are aware that Raptor users are currently experiencing a service interruption. Raptor Engineering has identified that the issue is related to a broader Microsoft Azure outage that is impacting several cloud services, including components used by Raptor systems.

Our team is closely monitoring Azure’s recovery progress while actively validating and implementing measures to restore full functionality to our platform as soon as possible.

We understand the impact this interruption is having on your district, and fully restoring service remains our top priority.

We will continue to provide updates as Azure’s services recover and our systems stabilize.

Thank you for your patience and understanding.
Posted Oct 29, 2025 - 12:07 CDT
This incident affected: Raptor.